読者です 読者をやめる 読者になる 読者になる

IT分からんわ~_~;

IT色々お勉強中のブログ

よくあるgem libv8とtherubyracerのインストールでエラーになるやつ

An error occurred while installing libv8 (3.16.14.7), and Bundler cannot continue. libv8はjavascript v8の何からしい bundle config build.libv8 --with-system-v8 こうするとlibv8はインストールできるがtherubyracerでエラー An error occurred whil…

bootstrap-switch-railsを使う

radioボックスをかっこよくしたかったんで Gemfile gem 'bootstrap-switch-rails', '~> 3.3.1' application.js //= require bootstrap-switch javascripts設定 $("body.news").ready -> $('input:checkbox').bootstrapSwitch() あとはviewに普通に書くだけ、…

gem AASMを使う

gem AASMとは rubyに有限オートマトンを追加する為のもの(ステータス管理を簡単にするもの) class or moduleに定義する↓ #AASMをinclude include AASM #columnで対象のカラム、enum使う場合はenum:true aasm column: :hoge, enum: false do # 使うステー…